没有人没抢过红包吧…… 这里给出N个人之间互相发红包、抢红包的记录,请你统计一下他们抢红包的收获。

输入格式:

输入第一行给出一个正整数N(≤104),即参与发红包和抢红包的总人数,则这些人从1到N编号。随后N行,第i行给出编号为i的人发红包的记录,格式如下:

K N1 P1 ⋯ NK PK

其中K(0≤K≤20)是发出去的红包个数,N*i是抢到红包的人的编号,P*i(>0)是其抢到的红包金额(以分为单位)。注意:对于同一个人发出的红包,每人最多只能抢1次,不能重复抢。

输出格式:

按照收入金额从高到低的递减顺序输出每个人的编号和收入金额(以元为单位,输出小数点后2位)。每个人的信息占一行,两数字间有1个空格。如果收入金额有并列,则按抢到红包的个数递减输出;如果还有并列,则按个人编号递增输出。

输入样例:

1
2
3
4
5
6
7
8
9
10
11
10
3 2 22 10 58 8 125
5 1 345 3 211 5 233 7 13 8 101
1 7 8800
2 1 1000 2 1000
2 4 250 10 320
6 5 11 9 22 8 33 7 44 10 55 4 2
1 3 8800
2 1 23 2 123
1 8 250
4 2 121 4 516 7 112 9 10

输出样例:

1
2
3
4
5
6
7
8
9
10
1 11.63
2 3.63
8 3.63
3 2.11
7 1.69
6 -1.67
9 -2.18
10 -3.26
5 -3.26
4 -12.32

思路

在结构体中记录相关变量,按题目要求模拟,需要注意排序函数的比较顺序。

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include <algorithm>
#include <cmath>
#include <cstring>
#include <iostream>
using namespace std;
const int Max = 10010;
struct List {
int num; //编号
int money; //拥有金额
int n; //抢红包的个数
} list[Max];
bool cmp(List a, List b) {
if (a.money != b.money) {
return a.money > b.money;
} else if (a.n != b.n) {
return a.n > b.n;
} else {
return a.num < b.num;
}
}
int main() {
int n, x, y, z, temp;
scanf("%d", &n);
for (int i = 0; i < n; i++) {
scanf("%d", &x);
int sum = 0;
while (x--) {
cin >> y >> z;
list[y - 1].money += z;
list[y - 1].n++;
sum += z;
}
list[i].money -= sum;
list[i].num = i;
}
sort(list, list + n, cmp);
for (int i = 0; i < n; i++) {
cout.precision(2);
cout << list[i].num + 1 << " " << fixed << list[i].money * 1.0 / 100
<< endl;
}
return 0;
}